EasyNote SL65-U-020FR

De ClissXXI.

Modèle "EasyNote SL65-U-020FR" (Packard Bell) (présent sur Linux on Laptops)

Caractéristiques:

  • Intel(R) Pentium(R) Dual CPU T3400 @ 2.16GHz
  • 250Go DD
  • 3Go RAM
  • ATI Radeon HD 3430
  • Écran 17' 16:10
# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 95c2
01:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
0a:01.0 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
0a:01.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 02)
0a:01.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)
  • Problème réseau à l'installation, mais aucun soucis une fois le système installé (depuis le CD1).
  • xorg.conf: forcer le pilote "radeon" (pas "radeonhd"):
Section "Device"
        Identifier      "Configured Video Device"
        Driver "radeon"
EndSection

Voir aussi: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=516890

  • Si l'écran est "flou" au démarrage, passer en mode texte (Ctrl+Alt+F1) puis de nouveau en mode graphique (Ctrl+Alt+F7)
  • Pas encore d'accélération 3D (pilote R600/R620).
  • Configuration (à titre informatif):
    • Radeon HD 34xx Series
    • xserver-xorg 1:7.3+18
    • xserver-xorg-video-radeon 1:6.9.0-1+lenny4
    • Setting screen physical size to 367 x 229
    • Modeline "1440x900"x0.0 96.30 1440 1648 1680 1760 900 903 909 912 -hsync -vsync (54.7 kHz)
cat <<EOF >> /etc/pm/config.d/defaults
SLEEP_MODULE="uswsusp"
S2RAM_OPTS="-f -a 3"
EOF
    • Mais ça ne fonctionne pas (S2RAM_OPTS pas encore géré), seule solution: patcher /usr/lib/pm-utils/modules.d/uswsusp, fonction do_suspend (c'est à ce demander ce que S2RAM_OPTS fait dans le wiki Debian depuis 2008?!?):
s2both --force $OPTS -a 3
  • Mise en veille prolongée: OK
  • Webcam OK
  • Son:
    • Mettre à jour alsa:
apt-get install -t experimental alsa-base  # nécessaire?
apt-get install alsa-source  # avec les dépendances stable
apt-get install -t experimental alsa-source  # mettre à jour en 1.0.18a
cd /usr/src
m-a a-i alsa-source  # c'est un peu long
    • Ajouter dans /etc/modprobe.d/alsa-base:
options snd-hda-intel model=g71v
options snd-hda-intel enable_msi=1
    • Recharger alsa
alsa force-reload

Voir aussi http://doc.ubuntu-fr.org/audio_intel_hda#notes

  • WiFi: rien n'est détecté, iwconfig est muet, lspci aussi...