Installation logicielle de la caméra

De ClissXXI.

Dans le cadre de Utopia 2005, CLISS XXI met en oeuvre une solution de visio conférence, reposant complètement sur des logiciels libres. Voici le descriptif technique, concernant l'installation de la caméra.

Les différents postes informatiques concernés par la visio conférence sont équipés de micro et d'une caméra internet (web caméra, ou webcam).

En dehors des aspects logiciels (on verra plus loin la Configuration de Gnomemeeting) il n'y a pas de problème particulier concernant la configuration du micro et des enceintes : ils sont physiquement connectés à la carte son, et il est possible de tester la bonne marche du dispositif simplement en parlant dans le micro. Les règlages divers (volume, basses, balance ...) peuvent être peaufinés, sous GNU/Linux, grâce à un logiciel tout simple, mais bien pratique, aumix, qui peut s'utiliser même dans un terminal alphanumérique.

Concernant la mise en place d'un module de gestion vidéo, on veille au préalable à l'existence du device approprié : /dev/video0. Si ce n'est pas le cas, on l'initialise : mknod /dev/video0 c 81 0 et on le rend éventuellement accessible à tous les utilisateurs : chmod 666 /dev/video0.

Les caméras sont des Philips ToUcam 2 PCVC 820K, qui se connectent sur l'ordinateur par un port USB. En général, les distributions GNU/Linux modernes incluent par défaut, et dès l'installation (pensez cependant à connecter physiquement la caméra au port USB ;-)) le module ov511.

C'est un module qui convient pour un grand nombre de caméras... mais pas pour les Philips ToUcam 2 PCVC 820K :-(
En effet, le module ov511 ne contient pas de décompression, ce qui est indispensable pour ce modèle de caméra. Il faut donc installer un autre driver : le driver ov51x, qui gère le module de décompression ov518_decomp. Nous détaillons maintenant ces différentes configurations, mais on peut au préalable se reporter au site alpha.dyndns.org


Comme il nous faudra compiler un driver, et générer deux modules, se pose inévitablement la question du noyau Linux concerné par le chargement de ces modules. Il s'agit d'installations spécifiques, que CLISS XXI réalise dans le cadre de UTOPIA 2005. Raison de plus pour se faire plaisir ;-))
Nous choisissons de travailler sur le dernier noyau stable disponible : le noyau 2.6.11.5, qui est disponible depuis le 18 mars 2005.

La configuration type sur laquelle nous implémentons la solution de visio conférence est donc la suivante :

  • Debian GNU/Linux Sarge (dans le cadre d'une installation par internet, elle est livrée avec un noyau 2.6.8).
  • Recompilation d'un nouveau noyau : le 2.6.11.5

La recompilation et l'installation d'un nouveau noyau ne font pas l'objet de cet article. Disons simplement que, à l'issue de la mise en place du nouveau noyau, notre système GNU/linux dispose de toute l'arborescence des sources du noyau, dans /usr/src (ce n'est pas le cas au moment de l'installation initiale : les sources ne sont pas installés, et, pour aller plus loin, une autre solution, dans ce cas, peut consister à télécharger les fichiers d'en-tête du noyau, les fameux kernel-headers).


La compilation des sources du driver :
En première approche, il ne semble pas y avoir de souci :

  • On télécharge les sources sur alpha.dydndns.org (ov51x-1.65-1.11-mark).
  • On décompresse tout ça dans un répertoire temporaire.
  • On lance la compilation : make
  • Tout semble OK, à peine remarque-t-on un ou deux warnings, concernant des symboles non définis.

L'installation des drivers :
Il s'agit de deux modules du noyau, d'extension .ko (kernel objects) : ov51x.ko et ov518_decomp.ko

A partir de là, on peut mettre en place ces modules, et les charger :

  • cp ov51x.ko /lib/modules/2.6.11.5/kernel/drivers/usb/media/ et cp ov518_decomp.ko /lib/modules/2.6.11.5/kernel/drivers/usb/media/ (pour installer les 2 modules)
  • depmod (pour générer /lib/modules/2.6.11.5/modules.dep)
  • modprobe ov51x (pour charger une première fois à la main notre joli module)

Et là... patatras... on a droit à une toute aussi jolie FATAL ERROR : unresolved symbols.
Autrement dit, ça nous apprendra à ne pas tenir compte des warnings au moment de la compilation :-(

Que s'est il passé ? Les sources du module ne passent plus sur les sources d'un noyau récent, qui gère une table de symboles qui a évolué. Deux solutions :

  • revenir à un noyau plus ancien :-(
  • corriger les symboles non résolus.

C'est donc ce que nous faisons. Heureusement, ce n'est pas bien compliqué : on relance le chargement du module et on trace la FATAL ERROR : c'est la fonction remap_page_range() qui est concernée. Il suffit de la remplacer, dans le code source ov51x.c, par la fonction io_remap_page_range(), qui est celle que gère le noyau 2.6.11.5

Et on recommence :

  • make
  • copie des .ko
  • depmod
  • modprobe

Cette fois ci, tout est OK. On vérifie que tout s'est bien passé, avec dmesg et lsmod. Et on peut passer à la suite : la Configuration de Gnomemeeting.


Sommaire

[modifier] Compilation

Généralement: une version du pilote datant de 2003 est incluse dans le noyau. Elle ne fonctionne pas. Il faut donc utiliser une version plus récente. Cette version plus récente n'évolue plus depuis 2006; un patch est disponible qui fonctionne avec le noyau 2.6.22 (2007). Une plus vieille version [1] a été reprise et compile avec les noyaux récents mais est moins fonctionnelle.

Il est donc nécessaire qu'un développeur mette à jour le code de ov511 2.xx...

[modifier] Sous Debian Lenny

Le paquet ov511-source n'est plus disponible en paquet [2]. La version incluse dans le noyau est plus ancienne et pose des problèmes [3].

ov51x-jpeg-source est une alternative. Correct si on force en 352x288, mais affichage aléatoire (blocs de couleurs en changement permanent) en 160x120.

Nous avons eu des résultats plus corrects avec une Labtech (plutôt que la Philips).

[modifier] Sous Debian testing (2/2008)

Le module n'a pas été mis à jour depuis Etch et ne compile plus avec les noyaus plus récents (2.6.22).

Le bug 406720 fournit à un patch à appliquer:

aptitude install fakeroot ov511-source
m-a a-i ov511 # ça ne fonctionne pas
cd /usr/src/modass/usr_src/modules/
patch -p0 < /tmp/ov511_2.6.19.diff
# on recompile avec --not-unpack pour ne pas écraser nos changements
m-a --not-unpack a-i ov511

[modifier] Sous Debian Etch

Compile sans soucis:

aptitude install fakeroot ov511-source
m-a a-i ov511

[modifier] Post-installation

modprobe ovcamchip
echo "ovcamchip" >> /etc/modules

Puis assurez-vous:

  • de faire partie du groupe video (en principe ce est fait par défaut pour l'utilisateur principal de la machine)
  • d'avoir activé le module v4l (video for Linux) dans Xorg (sinon faites-le avec dpkg-reconfigure xserver-xorg)


[modifier] Tester

mplayer tv:// -tv driver=v4l   # petite résolution
mplayer tv:// -tv driver=v4l:width=352:height=288 -aspect 4:3   # grande résolution
v4l-info # get textual information, paquet 'v4l-conf'

Fonctionne ici sous Ekiga, Kopete (packet etch-backports v3.5.7, problème avec le paquet Etch v3.5.5) et aMSN.


[modifier] Liens