Backport GCJ

De ClissXXI.

J'ai essayé de backport-er java-gcj-compat pour utiliser OOo2 Base, mais ça n'a pas fonctionné:

# Create a jail to avoid messing with the current system
# (library version mismatch prevented Firefox from running last time I tried - ahem)
debootstrap sarge /jails/sarge http://mirror:9999/debian
# In the jail:
# Usual virtual file systems
mount procfs -t proc /proc
mount devptsfs -t devpts /dev/pts
mount sysfs -t sysfs /sys
aptitude upgrade
aptitude install apt-src
aptitude install less emacs # ...

# We compile etch's version of gij for Sarge
# Edit /etc/apt/sources.list: include sarge and etch
# Just _don't upgrade_ to Etch, even though we'll need to grab some build-deps from it

# Compilation per se
cd /usr/src
apt-src install  gij-4.0
apt-src build -k gij-4.0

apt-src install  java-gcj-compat
apt-src build -k java-gcj-compat


# Outside the jail:
aptitude install fastjar libjessie-java
dpkg -i gij-4.0_4.0.2-5j2_i386.deb libgcj6_4.0.2-5j2_i386.deb
dpkg -i java-gcj-compat_1.0.30-4_i386.deb libgcj6-common_4.0.2-5j2_all.deb

/etc/apt/sources.list:

# Stable
deb http://mirror:9999/debian sarge main
deb http://mirror:9999/security sarge/updates main
# Testing
deb http://mirror:9999/debian etch main contrib
deb-src http://mirror:9999/debian etch main contrib

/etc/apt/preferences:

Package: *
Pin: release a=testing
Pin-Priority: 300

Pour le moment ça ne fonctionne pas (OOo plante). À suivre...


Je viens de voir ce post: http://mjg59.livejournal.com/52060.html

Apparemment il y a un gros foutoir avec libgcc4 :/

Outils personnels