Backport Gnash

De ClissXXI.

Version 0.8.4

Almost all dependencies are available in Etch, so it's pretty easy to install.

Only 'base-files' needs to be backported, and it was already uploaded at backports.org by another backporter.

For licensing reasons, Qt3 needed to be backported as well (because that backported version was released under the GPLv3, while Etch's was GPLv2 only). See http://lists.backports.org/lurker-bpo/message/20080408.192906.84b6a444.en.html

  • Enable backports repository:
cowbuilder --login --save-after-login
echo "deb http://network/mirrors/debian-backports.org etch-backports main" > /etc/apt/sources.list.d/bpo.list
wget -O - http://backports.org/debian/archive.key | apt-key add -
aptitude update
  • In /etc/pbuilderrc, use the 'experimental' method to satisfy dependencies:
PBUILDERSATISFYDEPENDSCMD="/usr/lib/pbuilder/pbuilder-satisfydepends-experimental

Normally the backports repository will not be used, because it has a default priority of -1. With the 'experimental' method (meant for the Debian experimental repository), backports dependencies will be used, but only if no Stable dependency could be found first, which is exactly what we want.

The dependencies are already edited for use in backports.org (e.g. base-files (>= 4.0.1~)) so we don't have to do any change to the package. Marvelous. Build-Depends dependencies are not edited though so we still need to change it there (this will be fixed in the next package upload [1]).

We can proceed with the backport:

export DEBEMAIL="beuc@beuc.net" 
export DEBFULLNAME="Sylvain Beucler"
export EDITOR="emacs"
yes | dch -D etch-backports \
  --newversion $(dpkg-parsechangelog | sed -ne 's,^Version: ,,p')~bpo40+1 \
  --force-bad-version -- \
  "Rebuild for Debian Backports <http://www.backports.org/>"
sed -i -e "s/Uploaders:\(.*\)/Uploaders:\1, $DEBFULLNAME <$DEBEMAIL>/" debian/control
# TODO: --pbuildersatisfydepends doesn't work, why?
#pdebuild --pbuilder cowbuilder --pbuildersatisfydepends /usr/lib/pbuilder/pbuilder-satisfydepends-experimental
# Meanwhile we edit /etc/pbuilderrc manually
pdebuild --pbuilder cowbuilder --debbuildopts '-sa'
# If you're compiling from Lenny:
#pdebuild --pbuilder cowbuilder -- --basepath /var/cache/pbuilder/base-etch.cow --debian-etch-workaround --debbuildopts '-sa'


Version 0.8.5

In debian/control:

  • Change libgif-dev to libungif4-dev
  • Change kdelibs5-dev to kdelibs4-dev
  • Remove libcsound64-dev (new Lenny subpackage from csound)
  • Remove libswscale-dev (new Lenny subpackage from ffmpeg)
  • Remove qt4-qmake (new Lenny subpackage from qt4-x11)

In debian/rules:

  • Replace kde4 by kde3 (in --enable-gui="gtk,kde4")

In configure.ac:

  • Force ltver=1.x around line 800

In autogen.sh:

  • Add --automake to libtoolflags

There are problems with libtool... Confirmed here:

This is fixed in the trunk - but that doesn't help with building this particular release :)


Liste des dépendances à installer pour tester manuellement: dpkg-dev debhelper quilt sng dh-buildinfo autoconf automake libtool autotools-dev libltdl3-dev libxmu-dev dejagnu libboost-dev libboost-thread-dev libgtkglext1-dev libjpeg-dev libpng12-dev libungif4-dev libagg-dev libpango1.0-dev libsdl1.2-dev libcurl3-gnutls-dev libboost-date-time-dev libavcodec-dev libavformat-dev libspeex-dev kdelibs4-dev libqt4-dev qt4-dev-tools csound


Pour un backport Lenny, cf.:

deb http://debian.jones.dk/ lenny gnash

Back to Backports.

Outils personnels