Discussion:Compatibilité binaire

De ClissXXI.

J'ai un soucis avec le GLIB_2.0, entre 3 serveurs :

- kernel une 2.6.8, debian stable, un executable de paiement fonctionne correctement - un autre serveur que l'on a force a passer en 2.6.15 (etch) pour installer le kernel de cette version, puis on est repasse en stable (pour des raisons de compatibilite HARD avec un chipset tres recent), l'executable renvoie un erreur GLIBC_2.0 - un autre serveur qui lui est en etch, erreur aussi :

./request: relocation error: ./request: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

Existe t il une solution ? un package de compatibilite qui manquerait ou dois je demander une autre version de l'executable ?


En principe, la compatibilité arrière est conservée dans glibc - donc un exécutable qui fonctionne sous glibc/sarge devrait fonctionner sans modification sous glibc/etch.

$ objdump -T /lib/libc.so.6 | grep errno
# sarge:
0012fc80 g    DO .bss   00000004  GLIBC_2.0   errno
# etch:
0011f360 g    DO .bss   00000004 (GLIBC_2.0)  errno

Donc ça devrait fonctionner. S'agit-il d'un x86?

Ce problème en cache ici un autre: l'impossibilité de recompiler un logiciel propriétaire. Si ce n'est pas indiscret, quelle est la solution de paiement en question? Nous avons des échanges avec ATOS à ce sujet en ce moment.

Outils personnels