HP DeskJet D2460

De ClissXXI.

Paquets:

aptitude install hpijs-ppds # needed?

=> sous Etch, le pilote recommandé "HP Deskjet D2300 / hpijs" ne fonctionne pas.


L'imprimante a en effet besoin de hplip en version >= 1.7.4 (avril 2007), cf. les imprimantes gérées par hplip.

Télécharger la version en fichier .run.

aptitude purge hpijs hpijs-ppds
aptitude install build-essential libjpeg-dev
sh hplip-2.7.10.run
# => c=custom
# => s=single func

Avec plus de choses (autres que l'impression stricte) à compiler:

aptitude install python-dev libcupsys2-dev libusb-dev libtool
sh hplib-2.7.10.run
# a=automatic
# Reported missing optional dependencies:
# libnetsnmp-devel pyqt reportlab sane-devel scanimage xsane sane

foomatic (/usr/lib/ppr/interfaces/foomatic-rip) est utilisé d'une manière ou d'une autre dans la chaîne d'impression:

aptitude install foomatic-filters

Par défaut, l'imprimante n'utilise que la cartouche couleur pour imprimer. Aller dans les préférences de l'imprimante (http://localhost:631/printers/DeskJet-D2400) pour sélectionner l'utilisation d'une des deux cartouches uniquement, ou des deux cartouches combinées. (ça n'a pas l'air de bien fonctionner depuis l'interface "Impression" de Gnome, par contre).


Liens

Outils personnels