Konica Minolta Magicolor 2300DL

De ClissXXI.

Installation du pilote (manuel)

aptitude install --assume-yes build-essential libcupsys2-dev libcupsimage2-dev liblcms1-dev
aptitude install --assume-yes foomatic-filters-ppds
cd /usr/src/
wget http://www.cl.cam.ac.uk/~mgk25/download/jbigkit-1.6.tar.gz
tar xzf jbigkit-1.6.tar.gz
pushd jbigkit
make
install -D -m644 ./libjbig/libjbig.a /usr/local/lib/libjbig.a
install -D -m644 ./libjbig/jbig.h /usr/local/include/jbig.h
popd
#wget http://printer.konicaminolta.net/drivers/linux/2430DL_sc_linux.tar.gz
#tar xzf 2430DL_sc_linux.tar.gz
#cd magicolor2430DL-1.5.0/
wget http://www.linuxprinting.org/download/printing/konicaminolta/magicolor2430DL-1.6.0.tar.gz
tar xzf magicolor2430DL-1.6.0.tar.gz
pushd magicolor2430DL-1.6.0/
# cancel wrong lib64 trick:
sed -i -e 's#/lib64#/lib#' configure
# update PPD location
sed -i '/KM_PPDDIR/s#/usr/share/cups/model/KONICA_MINOLTA#"$datadir/ppd/"#' ./configure
./configure
make
make install
popd
invoke-rc.d cupsys restart

Utiliser ensuite:

  • socket://192.168.1.X:9100
  • modèle: KONICA MINOLTA / magicolor 2430 DL

Installation Debian (Etch)

Pas probant :/

Utilisation du pilote 'foo2zjs':

aptitude install foomatic-filters-ppds

Vous avez ensuite accès au pilote avec la marque 'Konica' ou 'KonicaMinolta'. Mais je n'ai pas réussi à le faire fonctionner.

Liens

Outils personnels