Problèmes OpenOffice courants

De ClissXXI.

Sommaire

Tableau dont la fin est masquée

Cela se passe pendant l'import d'un document Word.

Il se peut que votre tableau soit inclus dans un "cadre". Un cadre a une taille fixe et permet de borner la taille d'un élément, comme une image qu'on veut afficher partiellement, ou donc un tableau.

Il semble que OpenOffice restreigne les "cadres" à une seule page, ce qui masque la fin du tableau, qui est "trop grand" pour entrer en entier dans le cadre.

Une piste: couper/coller le tableau en dehors de cadre.

  • Je clique sur une cellule du tableau
  • Je fais "Édition > Tout sélectionner" *deux fois d'affilée* pour sélectionner tout le tableau (une seule fois, ça ne sélectionne que la cellule courante)
  • Édition > Couper
  • Je clique sur la première page vide
  • Édition > Coller

Il reste le cadre avec un tableau vide. Je clique sur le bord du cadre vide et j'appuie sur Suppr.

Installer une police

Le plus simple:

  • À faire la première fois:
    • Ouvrir l'explorateur de fichiers (Nautilus)
    • Cocher Affichage > Afficher les fichiers cachés (Ctrl+H)
    • Cliquer sur Fichier > Créer un dossier (Ctrl+Shift+N)
    • Nommer ce dossier .fonts
  • Mettre votre police (fichier .ttf) dans ce dossier .fonts
  • Relancer OpenOffice

Plus compliqué (mode administrateur):

  • Copier la police dans /usr/share/fonts
  • Exécuter (optionnel?):
fc-cache -f -v

Obtenir une virgule quand on tape le [.] du pavé numérique dans Calc

Normalement ça fonctionne d'office, pourvu qu'on soit bien en langue française:

Outils > Options > Paramètres Linguistiques > Langues

Cocher également:

Touche séparateur de décimales > Identique à l'environnement linguistique

Si la touche [.] fait toujours un point au lieu de la virgule dans Calc, modifiez vos paramètres de clavier dans GNOME comme suit dans:

Bureau > Préférences > Clavier
> Agencements
> Options de l'agencement
> Numeric keypad layout selection > Legacy keypad

Image:Ooo-virgule.png

Retrouver mon dossier personnel

Lorsque l'on fait "Enregistrer sous...", une des icônes en haut à droite de la fenêtre d'enregistrement de fichier permet de retourner directement dans /home/mon_nom_d_utilisateur

Correction anglaises

Quand on tape "responsable", OpenOffice remplace par "responsible". C'est que la langue du document est l'anglais:

  • Outils/Options/Paramètres linguistiques/Langue -> Français (France)

On peut également désactiver ce genre de corrections (ToDo).

Changer l'orientation de ma page (portrait / paysage)

Ce n'est pas au même endroit que dans MS Office, il faut aller dans le menu Format -> Page. Dans la fenêtre qui vient de s'ouvrir, cliquez si besoin sur l'onglet Page.

Mode "correction"

Éditer -> Modification -> Enregistrer

Cela permet d'enregistrer toutes les modifications apportées à un document. On peut s'en servir pour corriger le rapport d'un collègue et lui permettre d'étudier facilement les changements apportés.

Changer une police par une autre

Dans Édition->Rechercher et remplacer, il y a un menu Format... qui permet de remplacer un format par un autre, par exemple une police par une autre.

Pour cela, cliquer dans le champ Rechercher, cliquer sur Format..., sélectionner la police à remplacer.

Puis cliquer dans le champ Remplacer, cliquer sur Format... à nouveau, et sélectionner la police de remplacement.

On peut voir, à côté des champs Rechercher et Remplacer, le style sur lequel ils s'appliquent.

Imprimer plusieurs pages par feuille

[ToDo: utiliser les noms exacts des fonctions]

Tout d'abord, allez dans Fichier->Paramètres de l'imprimante, choisissez l'imprimante sur laquelle vous allez imprimer, puis cliquer sur OK. Cela dit à OpenOffice de faire des calculs de positionnement des pages en tenant compte de cette imprimante.

Ensuite, cliquez sur Fichier->Aperçu avant impression, puis sur le bouton sur droite de la barre d'outils. Dans la fenêtre qui s'ouvre, modifiez les valeurs lignes/colonnes dans Répartition, et jouer sur Portrait/Paysage.

Le résultat n'est pas visible dans l'aperçu, mais sera pris en compte à l'impression.


Suppression de pages vides lors d'un publipostage

Lors d'un publipostage, OpenOffice.org Writer insère des pages vides entre chaque élément résultant de la fusion. Il est possible de supprimer ces pages vides, au moment de l'impression.

1ère méthode : Paramétrage de l'imprimante

  • Fichier ---> Paramétrage de l'imprimante


  • ---> Options


  • Il suffit alors de décocher la case Imprimer automatiquement les pages blanches insérées


  • Le résultat est visible à l'aperçu, et quand on imprime

2ème méthode : Options des impressions sous Writer

  • Outils ---> Options ---> OpenOffice.org Writer ---> Impression


  • Comme dans la 1ère méthode, il suffit de décocher la case Imprimer automatiquement les pages blanches insérées
  • On obtient les mêmes résultats, au moment de l'aperçu ou de l'impression : les pages vides sont supprimées.


Ne pas imprimer les champs vides lors d'un publipostage

On souhaite réaliser un publipostage dont un ou plusieurs champs peuvent être vides.


Dans notre exemple, on écrit à des Maires, dont certains occupent une autre fonction (Député, Sénateur, Conseiller général, etc ...)

Le publipostage gère donc le champ Titre, qui peut être vide ou non.


  • Pour les maires qui occupent une autre fonction, le <Titre> est bien imprimé (ici : Député, dans la capture d'écran ci-dessus).


  • À l'opposé, pour les maires qui n'occupent pas d'autres fonction, une ligne blanche est imprimée.

C'est cette ligne blanche que l'on souhaite supprimer.

  • On se place devant le champ <Titre>
  • Insertion ---> Champ ---> Autres ou raccourci clavier Ctrl F2
  • Fonctions ---> Paragraphe masqué


  • Dans le champ Condition, on indique not(Titre), dans le cas où le champ concerné s'appelle Titre


  • Au final, la ligne vide est bien supprimée



Enlever des protections en écriture d'un document

Pour pouvoir écrire de nouveau dans page :

Allez dans Format -> Sections...

cliquer sur le nom de la section

puis décocher la case protégé en dessous de Protection contre les modifications.

Supprimer l'historique des modifications

Contexte

  • OpenOffice.org 3 sous Debian GNU/Linux
  • L'option Edition -> Modifications -> Enregistrer permet d'enregistrer les modifications / ajouts / suppressions successifs apportés à un document par différents auteurs, dans le cadre d'un travail collaboratif sur ce document.
  • L'option Edition -> Modifications -> Afficher permet d'afficher ces modifications, qui apparaissent alors dans le texte, sous des couleurs différentes selon les auteurs, avec affichage de l'auteur de chaque modification, et l'horodatage de chaque modification.
  • Les modifications enregistrées portent sur :
    • les insertions
    • les suppressions
    • les modifications d'attributs (gras, souligné, ...)

La question posée

  • On souhaite envoyer notre document à un tiers.
  • Ce tiers va avoir accès à l'historique des modifications, ce qu'on peut ne pas souhaiter.
  • une première réponse peut consister à envoyer un PDF. Ce n'est pas toujours possible, notamment dans le cas de documents à compléter par le destinataire.


Pour comprendre comment ça fonctionne

  • Dans le cadre d'un travail collaboratif, la gestion des modifications peut effectivement être utile pour historiser les modifications de chaque auteur.
  • La gestion des modifications permet également de revenir en arrière, en acceptant ou refusant telle ou telle modification, ou en revenant à une version antérieure.
  • La méthode pour choisir des modifications, les accepter ou les refuser consiste à activer l'option Edition -> Modifications -> Accepter ou rejeter
  • Cette option permet notamment au coordinateur de la rédaction du document, en phase finale, de valider ou non les modifications des différents auteurs.


  • Avec cette option, il est possible d'intervenir finement sur chaque modification. Dans le cas de nombreuses modification à traiter, l'onglet Filtre permet de ne traiter que certaines modifications, en fonction de critères donnés (date, auteur, etc ...)

Revenons à la question posée

  • Si on a travaillé sur un document de manière incrémentale, et que, au final le document modifié par les différents auteurs est le document définitif, il suffit alors de valider toutes les modifications intermédiaires : Edition -> Modifications -> Accepter ou rejeter -> Tout accepter. Après enregistrement, l'historique de toutes les modifications aura disparu, et on pourra sans crainte envoyer le document à nos correspondants.

arrêter la proposition automatique de complément des mots lors de la frappe

Sélectionnez le menu Outils > AutoCorrection.

Sélectionnez l'onglet Insertion Automatique.

Décochez la case Compléter les mots.

Cliquez sur OK.

Pour Calc, sélectionnez le menu Outils > Contenu des cellules > AutoSaisie.

Fusionner automatiquement 2 cellules sur plusieurs lignes dans calc

Il est possible d'utiliser la fonction CONCATENER(B1;C1) pour fusionner sur une autre collone et de répeter cette formule sur plusieurs lignes.

Images ...

Incorporer les images liées au document

Pour incorporer des images lié au document : menu Édition > Liens

sélectionner les images puis Cliquez sur le bouton Rompre le lien.

cf. : http://wiki.services.openoffice.org/wiki/FR/Documentation/Writer_Guide/Ajout_images

Mes images ne s'affichent pas/ ne s'impriment pas

Selon que ce soit un document de traitement de texte, ou un tableur, les options ne se trouvent pas tout à fait au même endroit:

De manière générale, vérifier

  • les options d'affichage et d'impression (outil->options->writer->affichage/impression)
  • et/ou le format de page (format->page->classeur...)

OpenOffice.org 1 sur un montage NFS

Le README.Debian dit (pour la v1):

 If you are using NFS mounted file systems, you should make sure that locking is functioning:
 'Make sure NFS lockd is running on the client, or mount the NFS export which
 contains /usr with the 'nolock' option.
 
 If /usr gets mounted from an initrd, check 'ps' output once the system is
 fully booted to ensure that you see a [lockd] kernel process, or an
 'rpc.lockd' userspace process. 
 
 If not, just issue your mount command again (no need to even -o remount it
 seems!) and run /etc/init.d/nfs-common restart.' (Thanks to Gavin Hamill)
 
 See this mailing list thread for more information:
   http://lists.debian.org/debian-openoffice/2004/debian-openoffice-200402/msg00223.html

Si vous avez les memes problemes sur un FreeBSD, vous serez tentés de lancer /etc/rc.d/ rpcbind et nfslocking. Si votre serveur vous pose des problemes apres ca, oubliez les rpcbind et nfslocking. Lancez vos montages NFS a la main via un mount_nfs -L

Liens

Outils personnels